码迷,mamicode.com
首页 > 编程语言 > 详细

1008. 数组元素循环右移问题 (20)

时间:2017-03-19 15:32:16      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:数组元素   str   移动   span   i++   循环   设计   程序   system   

1008. 数组元素循环右移问题 (20)

 

一个数组A中存有N(N>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(M>=0)个位置,即将A中的数据由(A0A1……AN-1)变换为(AN-M …… AN-1 A0 A1……AN-M-1)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?

输入格式:每个输入包含一个测试用例,第1行输入N ( 1<=N<=100)、M(M>=0);第2行输入N个整数,之间用空格分隔。

输出格式:在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。

输入样例:

6 2
1 2 3 4 5 6

输出样例:

5 6 1 2 3 4

解法一:不管题目条件 另开数组
#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>

using namespace std;

int main()
{
    int a[150];
    int n, m;
    cin >> n >> m;
    m = m%n;
    for (int i = 0; i < n; i++)
    {
        cin >> a[i];
    }
    int cnt = 0;
    for (int i = n - m; i < n; i++)
    {
        cout << a[i];
        cnt++;
        if (cnt < n) cout << " ";
    }
    for (int i = 0; i < n-m; i++)
    {
        cout << a[i];
        cnt++;
        if (cnt < n) cout << " ";
    }





    system("pause");
    return 0;
}

 

1008. 数组元素循环右移问题 (20)

标签:数组元素   str   移动   span   i++   循环   设计   程序   system   

原文地址:http://www.cnblogs.com/brightz2017/p/6580458.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!