码迷,mamicode.com
首页 > 移动开发 > 详细

Happy 2006 欧几里得定理

时间:2017-04-03 14:42:18      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:ble   mon   which   std   can   turn   tip   0ms   fine   

Happy 2006
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 11956   Accepted: 4224

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006. 

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order. 

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5

Source

 

 

周期性!

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long LL;
#define MAXN 1000002
/*
要求找到与m互质的第k大的数字
gcd(a,b) = gcd(b*t+a,b)
*/
LL a[MAXN];
LL gcd(LL a,LL b)
{
    if(b==0)
        return a;
    return gcd(b,a%b);
}
int main()
{
    LL m,k;
    while(scanf("%lld%lld",&m,&k)!=EOF)
    {
        LL p=0;
        for(int i=1;i<=m;i++)
        {
            if(gcd(i,m)==1)
                a[++p] = i;
        }
        if(k%p==0)
            printf("%lld\n",(k/p-1)*m+a[p]);
        else
            printf("%lld\n",(k/p)*m+a[k%p]);
    }
}

 

Happy 2006 欧几里得定理

标签:ble   mon   which   std   can   turn   tip   0ms   fine   

原文地址:http://www.cnblogs.com/joeylee97/p/6661844.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!