码迷,mamicode.com
首页 > 编程语言 > 详细

算法复习——欧拉函数(poj3090)

时间:2017-04-03 23:05:27      阅读:324      评论:0      收藏:0      [点我收藏+]

标签:pass   val   技术   函数模板   算法   log   pst   output   dataset   

题目:

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

技术分享

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

题解:

欧拉函数模板题。

心得:

感觉欧拉函数稍微考得隐晦点的就是可视点问题了···嗯就这样

代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<ctime>
#include<cstring>
#include<string>
#include<algorithm>
#include<cctype>
using namespace std;
const int N=1006;
int phi[N],sum[N],n;
void pre()
{
  for(int i=1;i<N;i++)
    phi[i]=i;
  for(int i=2;i<N;i++)  
    if(phi[i]==i)
      for(int j=i;j<N;j+=i)
        phi[j]=phi[j]*(i-1)/i;
  for(int i=2;i<N;i++)
    sum[i]=phi[i]+sum[i-1];
}
int main()
{  
  //freopen("a.in","r",stdin);
  pre();
  scanf("%d",&n);
  for(int i=1;i<=n;i++)
  {
    int k;
    scanf("%d",&k);
    cout<<i<<" "<<k<<" "<<sum[k]*2+3<<endl;
  }
  return 0;
}

 

算法复习——欧拉函数(poj3090)

标签:pass   val   技术   函数模板   算法   log   pst   output   dataset   

原文地址:http://www.cnblogs.com/AseanA/p/6663753.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!