码迷,mamicode.com
首页 > 移动开发 > 详细

Pick apples 第三届acm省赛

时间:2017-04-28 23:44:55      阅读:323      评论:0      收藏:0      [点我收藏+]

标签:produce   input   eve   style   hid   ini   and   class   algo   

Description

 

Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because she has never seen so many apples before. Each kind of apple has a size and a price to be sold. Now the little girl wants to gain more profits, but she does not know how. So she asks you for help, and tell she the most profits she can gain.

 

Input

In the first line there is an integer T (T <= 50), indicates the number of test cases.
In each case, there are four lines. In the first three lines, there are two integers S and P in each line, which indicates the size (1 <= S <= 100) and the price (1 <= P <= 10000) of this kind of apple.

In the fourth line there is an integer V,(1 <= V <= 100,000,000)indicates the volume of the girl‘s bag.

Output

For each case, first output the case number then follow the most profits she can gain.

Sample Input

1
1 1
2 1
3 1
6

Sample Output

Case 1: 6

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
struct N
{
    int s,p;
    double pri;
} node[4];
bool cmp(N a,N b)
{
    if(a.pri<b.pri)        return true;
    return false;
}
long long llmax(long long a,long long b)
{
    return a>b?a:b;
}
int main()
{
    int t;
    cin>>t;
    int c=1;
    while(t--)
    {
        for(int i=0;i<3;i++){
            cin>>node[i].s>>node[i].p;
            node[i].pri = 1.0*node[i].s/(1.0*node[i].p);
        }
        int V;
        cin>>V;
        sort(node,node+3,cmp);
        long long ans=0;
        for(int i=0; i<node[0].s; i++)
        {
            for(int j=0; j<node[0].s; j++)
            {
                long long temp=i*node[1].s+j*node[2].s;
                if(temp>V)
                    break;
                else
                {
                    long long v=V-temp;
                    ans=llmax(ans,v/node[0].s*node[0].p+i*node[1].p+j*node[2].p);
                }
            }
        }
        cout<<"Case "<<c++<<": "<<ans<<endl;
    }
    return 0;
}

 

Pick apples 第三届acm省赛

标签:produce   input   eve   style   hid   ini   and   class   algo   

原文地址:http://www.cnblogs.com/upstart/p/6783571.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!