码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 2305 Basic remains(JAVA练习)

时间:2014-08-25 19:20:04      阅读:230      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   java   os   io   for   ar   div   

Description

Given a base b and two non-negative base b integers p and m, compute p mod m and print the result as a base b integer. p mod m is defined as the smallest non-negative integer k such that p = a*m + k for some integer a.

Input

Input consists of a number of cases. Each case is represented by a line containing three unsigned integers. The first, b, is a decimal number between 2 and 10. The second, p, contains up to 1000 digits between 0 and b-1. The third, m, contains up to 9 digits between 0 and b-1. The last case is followed by a line containing 0.

Output

For each test case, print a line giving p mod m as a base-b integer.

Sample Input

2 1100 101
10 123456789123456789123456789 1000
0

Sample Output

10
789
求p%m的b进制表示。果断java。
import java.io.*;
import java.math.*;
import java.util.*;

public class Main {
	public static void main(String[] arges){
        Scanner cin = new Scanner (System.in);
		int b;
		BigInteger p,m,ans;
		while(cin.hasNext())
		{
			b=cin.nextInt();
			String str;
			if(b==0)  break;
			p=cin.nextBigInteger(b);
			m=cin.nextBigInteger(b);
			ans=p.mod(m);
			str=ans.toString(b);
			System.out.println(str);
		}
	}
}


POJ 2305 Basic remains(JAVA练习)

标签:des   style   color   java   os   io   for   ar   div   

原文地址:http://blog.csdn.net/u013582254/article/details/38824245

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!