码迷,mamicode.com
首页 > 编程语言 > 详细

poj1159二维树状数组

时间:2017-05-03 13:11:07      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:else   time   题解   str   tab   ogr   oid   epo   maximum   

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 
技术分享

The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4
题意:1的话就是把x,y的位置+v,2的话就是求(x1,y1)到(x2,y2)之间的和
题解:二维树状数组,求和时用sum(x2+2,y2+2)-sum(x1+1,y2+2)-sum(x2+2,y1+1)+sum(x1+1,y1+1)即可
技术分享
#include<map>
#include<set>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<cstdio>
#include<iomanip>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define pi acos(-1)
#define ll long long
#define mod 1000000007
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1

using namespace std;

const double g=10.0,eps=1e-9;
const int N=1100+5,maxn=32000+5,inf=0x3f3f3f3f;

int c[N][N];

void add(int x,int y,int v)
{
    for(int i=x;i<N;i+=i&(-i))
        for(int j=y;j<N;j+=j&(-j))
           c[i][j]+=v;
}
ll sum(int x,int y)
{
    ll ans=0;
    for(int i=x;i>0;i-=i&(-i))
        for(int j=y;j>0;j-=j&(-j))
            ans+=c[i][j];
    return ans;
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
 //   cout<<setiosflags(ios::fixed)<<setprecision(2);
    int n,k,a;
    while(cin>>a>>n){
        memset(c,0,sizeof c);
        while(cin>>a){
            if(a==3)break;
            if(a==1)
            {
                int x,y,v;
                cin>>x>>y>>v;
                add(x+2,y+2,v);
            }
            else
            {
                int x1,y1,x2,y2;
                cin>>x1>>y1>>x2>>y2;
                cout<<sum(x2+2,y2+2)-sum(x1+1,y2+2)-sum(x2+2,y1+1)+sum(x1+1,y1+1)<<endl;
            }
        }
    }
    return 0;
}
View Code

 

poj1159二维树状数组

标签:else   time   题解   str   tab   ogr   oid   epo   maximum   

原文地址:http://www.cnblogs.com/acjiumeng/p/6801133.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!