码迷,mamicode.com
首页 > 移动开发 > 详细

UVALive 6084 Happy Camper(数学题)

时间:2017-06-10 10:45:45      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:article   size   技术   user   output   sed   pre   break   gen   

题目链接:https://icpcarchive.ecs.baylor.edu/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=4095

----------------------------------------------------------------------------------------------------------------------------------------------------------
欢迎光临天资小屋技术分享技术分享技术分享技术分享http://user.qzone.qq.com/593830943/main

----------------------------------------------------------------------------------------------------------------------------------------------------------

As Happy Camper Harry pulls into his favorite campground with his family, he notices the sign:
‘Campground occupancy is limited to 10 days within any consecutive 20-day period.‘ Harry is just
starting a 28-day vacation. What is the maximum number of days he can occupy a campsite during
his vacation?
We state the problem in more general terms. Suppose that 1 < L < P < V are integers. Camp-
ground occupancy is limited to L days within any consecutive P-day period. Happy Camper Harry
is just starting a V -day vacation. What is the maximum number of days he can occupy a campsite
during his vacation?


Input
The input will contain data for a number of test cases. For each test case, there will be one line of data,
containing values of L, P and V , in that order. All input integers can be represented by signed 32-bit
integers. End of data will be signaled by a line containing three zeros, which will not be processed.
Output
There will be one line of output for each test case. It will display the case number and the number of
days Happy Camper Harry can occupy a campsite during his vacation. The format is illustrated by
the sample output.
Sample Input
5 8 20
5 8 17
0 0 0
Sample Output
Case 1: 14
Case 2: 11


代码例如以下:

#include<stdio.h>
#define ll long long
int main()
{
	ll l,p,v;
	ll ans,temp;
	int cas=1;
	while(scanf("%lld %lld %lld",&l,&p,&v)!=EOF)
	{
		if(l==0 && p==0 && v==0)
			break;
		temp=v%p;
		if(temp>=l)
		{
			temp = l;
		}
		ans=(v/p)*l+temp;
		
		printf("Case %d: ",cas++);
		printf("%lld\n",ans);
	}
	return 0;
}


UVALive 6084 Happy Camper(数学题)

标签:article   size   技术   user   output   sed   pre   break   gen   

原文地址:http://www.cnblogs.com/mthoutai/p/6977769.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!