码迷,mamicode.com
首页 > 编程语言 > 详细

java hdu A+B for Input-Output Practice (III)

时间:2017-06-18 12:07:43      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:put   logs   script   inpu   class   practice   str   hdu   rmi   

 

A+B for Input-Output Practice (III)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 113961    Accepted Submission(s): 60127


Problem Description
Your task is to Calculate a + b.
 

 

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
 

 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

 

Sample Input
1 5 10 20 0 0
 

 

Sample Output
6 30
 

 

Author
lcy
 

 

值得注意的是怎么判断一个大数是否等于一个数,以及怎么把一个数转化为大数形式,注意大数实质上就是字符串

import java.math.BigInteger;
import java.util.Scanner;
public class Main//注意刷题时的java格式
{
    public static void main(String[] args)
    { 
        BigInteger a,b,d;
        String c = "0";
        d = new BigInteger(c);//将c转化为大数形式,用d保存
        Scanner in = new Scanner(System.in);
        while(in.hasNextBigInteger())
        {
            a = in.nextBigInteger();
            b = in.nextBigInteger();
            if(a.compareTo(d) == 0 && b.compareTo(d) == 0 )//注意用一个大数类自带方法来判断两个大数是否相等
                break;
            System.out.println(a.add(b));
        }
    }
}

 

java hdu A+B for Input-Output Practice (III)

标签:put   logs   script   inpu   class   practice   str   hdu   rmi   

原文地址:http://www.cnblogs.com/l609929321/p/7043714.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!