码迷,mamicode.com
首页 > 系统相关 > 详细

Hdu 1150 Machine Schedule

时间:2017-06-21 11:38:46      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:nim   from   amp   des   osi   term   input   man   memset   

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9038    Accepted Submission(s): 4541

Problem Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine‘s working mode from time to time, but unfortunately, the machine‘s working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

 

 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

 

 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

 

 

Sample Input

5 5 10

0 1 1

1 1 2

2 1 3

3 1 4

4 2 1

5 2 2

6 2 3

7 2 4

8 3 3

9 4 3

0

 

 

Sample Output

3

#include<string.h>
#include<stdio.h>
#define maxn 105int nx;
int ny;
int jobnum;
int g[maxn][maxn];
int ans;
int sx[maxn],sy[maxn];
int cx[maxn],cy[maxn];
int path(int u)
{
    sx[u]=1;
    int v;
    for(v=1;v<=ny;v++)
    {
        if((g[u][v])>0&&(!sy[v]))
        {
            sy[v]=1;
            if(!cy[v]||path(cy[v]))
            {
                cx[u]=v;cy[v]=u;
                return 1;
            }
        }
    }
    return 0;
}
void solve()
{
    ans=0;
    int i;
    memset(cx,0,sizeof(cx));
    memset(cy,0,sizeof(cy));
    for(i=1;i<=nx;i++)
    {
        if(!cx[i])
        {
            memset(sx,0,sizeof(sx));
            memset(sy,0,sizeof(sy));
            ans+=path(i);
        }
    }
}
int main()
{
    int i,j,k,m;
    while(scanf("%d",&nx)!=EOF,nx)
    {
        scanf("%d%d",&ny,&jobnum);
        memset(g,0,sizeof(g));
        for(k=0;k<jobnum;k++)
        {
            scanf("%d%d%d",&m,&i,&j);
            g[i][j]=1;
        }
        solve();
        printf("%d\n",ans);
    }
    return 0;
}

  

Hdu 1150 Machine Schedule

标签:nim   from   amp   des   osi   term   input   man   memset   

原文地址:http://www.cnblogs.com/zhangliu/p/7057893.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!