码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 1040.As Easy As A+B【排序】【如题(水!水!水!)】【8月24】

时间:2017-06-24 18:27:36      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:div   ace   pad   height   center   and   question   .net   rip   

As Easy As A+B

Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
It is guarantied that all integers are in the range of 32-int.
 

Output
For each case, print the sorting result, and one line one case.
 

Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 

Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
水题不解释:

#include<cstdio>
#include<algorithm>
using namespace std;
int main(){
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        int f[1010];
        for(int i=0;i<n;i++)
            scanf("%d",&f[i]);
        sort(f,f+n);
        for(int i=0;i<n;i++){
            if(i!=0) printf(" ");
            printf("%d",f[i]);
        }
        printf("\n");
    }
    return 0;
}

技术分享

HDU 1040.As Easy As A+B【排序】【如题(水!水!水!)】【8月24】

标签:div   ace   pad   height   center   and   question   .net   rip   

原文地址:http://www.cnblogs.com/yangykaifa/p/7073951.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!