码迷,mamicode.com
首页 > 编程语言 > 详细

HDU-5310-Souvenir(C++ && 简单数学题)

时间:2017-06-28 13:01:51      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:coder   注意   track   解析   needed   output   font   family   text   

Souvenir

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 416    Accepted Submission(s): 270


Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, wants to buy a souvenir for each contestant. You can buy the souvenir one by one or set by set in the shop. The price for a souvenir is  yuan and the price for a set of souvenirs if  yuan. There‘s  souvenirs in one set.

There‘s  contestants in the contest today. Soda wants to know the minimum cost needed to buy a souvenir for each contestant.
 

Input
There are multiple test cases. The first line of input contains an integer  , indicating the number of test cases. For each test case:

There‘s a line containing 4 integers  .
 

Output
For each test case, output the minimum cost needed.
 

Sample Input
2 1 2 2 1 1 2 3 4
 

Sample Output
1 3
Hint
For the first case, Soda can use 1 yuan to buy a set of 2 souvenirs. For the second case, Soda can use 3 yuan to buy a souvenir.
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5315 5314 5313 5312 5311 


BestCoder官方解析:
1001 Souvenir

本题是一个简单的数学题. 假设套装优惠的话就尽量买套装, 否则单件买. 注意一下假设一直用套装的话可能在最后的零头不如单买好, 即.



#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
    int t,n,m,p,q;//单位价格p元,套装q元,一个套装有m个纪念品,总共n个參赛者
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&n,&m,&p,&q);
        int price = 0;
        if(q/m<p)//假设套装优惠的话尽量买套装
        {
            if((n%m)*p<q)//假设在买套装最后零头的处理不如单位价格买廉价
            {
                price = (n/m)*q+(n%m)*p;//就在最后零头买单位价格
            }
            else
            {
                price = (n/m+1)*q;//否则多买一个套装
            }
        }
        else//否则直接单位价格买
        {
            price = n*p;
        }

        printf("%d\n",price);
    }
    return 0;
}


中文题目在以下:

 

Souvenir

 
 Accepts: 901
 
 Submissions: 2743
 Time Limit: 2000/1000 MS (Java/Others)
 
 Memory Limit: 262144/262144 K (Java/Others)
问题描写叙述
今天是BestCoder一周年纪念日. 比赛管理员Soda想要给每一个參赛者准备一个纪念品. 商店里纪念品的单位价格是元, 同一时候也能够花元购买纪念品套装, 一个套装里有个纪念品.

今天总共同拥有个參赛者, Soda想要知道最少须要花多少钱才干够给每一个人都准备一个纪念品.
输入描写叙述
输入有多组数据. 第一行有一个整数 , 表示測试数据组数. 然后对于每组数据:

一行包括4个整数  .
输出描写叙述
对于每组数据输出最小花费.
输入例子
2
1 2 2 1
1 2 3 4
输出例子
1
3
Hint
对于第一组数据, Soda能够1元购买一个套装. 对于第二组数据, Soda能够直接花3元购买一个纪念品.

HDU-5310-Souvenir(C++ &amp;&amp; 简单数学题)

标签:coder   注意   track   解析   needed   output   font   family   text   

原文地址:http://www.cnblogs.com/lytwajue/p/7088944.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!