码迷,mamicode.com
首页 > 编程语言 > 详细

算法总结——主席树(poj2104)

时间:2017-07-12 16:51:11      阅读:259      评论:0      收藏:0      [点我收藏+]

标签:images   struct   技术   har   sts   pac   not   tree   ring   

题目:

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

题解:

  主席树模板题,关于主席树的知识见下:

  技术分享技术分享技术分享技术分享

代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<ctime>
#include<cctype>
using namespace std;
const int N=100010;
int rank[N],root[N];
int n,m,tot;
struct node
{
  int x,id;
}a[N];
inline bool operator<(node a,node b)
{
  return a.x<b.x;
}
struct tree
{
  int l;
  int r;
  int sum;
}tr[N*20];
void build(int num,int &x,int l,int r)
{
  tr[tot++]=tr[x],x=tot-1;
  tr[x].sum++;
  if(l==r)  return;
  int mid=(l+r)/2;
  if(num<=mid)  build(num,tr[x].l,l,mid);
  else build(num,tr[x].r,mid+1,r);
}
int query(int i,int j,int k,int l,int r)
{
  if(l==r)  return l;
  int mid=(l+r)/2;
  int T=tr[tr[j].l].sum-tr[tr[i].l].sum;
  if(k<=T) return query(tr[i].l,tr[j].l,k,l,mid);
  else return query(tr[i].r,tr[j].r,k-T,mid+1,r);
}
int main()
{
  //freopen("a.in","r",stdin);
  int d,b,c;
  while(scanf("%d%d",&n,&m)!=EOF)
  {
    for(int i=1;i<=n;i++)
    {  
      scanf("%d",&a[i].x);
      a[i].id=i;
    }
    sort(a+1,a+n+1);
    for(int i=1;i<=n;i++)
      rank[a[i].id]=i;
    tot=1;
    for(int i=1;i<=n;i++)
    {
      root[i]=root[i-1];
      build(rank[i],root[i],1,n);
    }
    while(m--)
    {
      scanf("%d%d%d",&d,&b,&c);  
      cout<<a[query(root[d-1],root[b],c,1,n)].x<<endl;
    } 
  }
  return 0;
}

 

算法总结——主席树(poj2104)

标签:images   struct   技术   har   sts   pac   not   tree   ring   

原文地址:http://www.cnblogs.com/AseanA/p/7156269.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!