码迷,mamicode.com
首页 > Windows程序 > 详细

Windows Message Queue

时间:2017-07-21 15:48:44      阅读:308      评论:0      收藏:0      [点我收藏+]

标签:struct   队列   cas   eth   for   sim   mos   opera   val   

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.


Input

There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

 

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.

 

Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

 

Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!


优先队列。。简单

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
#include <string>

using namespace std;

struct mes
{
    string name;
    int par,pri;
    friend bool operator <(mes a,mes b)
    {
        return a.pri>b.pri;
    }
}temp;
int main()
{
   priority_queue<mes>q;
   string ins;
   while(cin>>ins)
   {
       if(ins=="GET")
       {
           if(!q.empty()){cout<<q.top().name<< <<q.top().par<<endl;q.pop();}
           else
           {
               cout<<"EMPTY QUEUE!"<<endl;
           }
       }
       else
       {
           cin>>temp.name>>temp.par>>temp.pri;
           q.push(temp);
       }
   }

}

 

Windows Message Queue

标签:struct   队列   cas   eth   for   sim   mos   opera   val   

原文地址:http://www.cnblogs.com/8023spz/p/7217378.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!