码迷,mamicode.com
首页 > Web开发 > 详细

poj 1258 Agri-Net

时间:2017-07-22 16:39:52      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:namespace   ssi   any   last   hat   class   sha   put   int   

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 59025   Accepted: 24473

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

/*
* @Author: Lyucheng
* @Date:   2017-07-22 11:40:20
* @Last Modified by:   Lyucheng
* @Last Modified time: 2017-07-22 15:44:49
*/
/*
 题意:给你一个图然后求最小生成树

 思路:裸的
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>

#define MAXN 105

using namespace std;

struct Node{
    int u,v;
    int val;
    Node(){}
    Node(int x,int y,int z){
        u=x;
        v=y;
        val=z;
    }
    bool operator < (const Node & other) const{
        return val<other.val; 
    }
};
int n;
int x;
vector<Node>edge;
int bin[MAXN];

int findx(int x){
    int cur=x;
    while(x!=bin[x]){
        x=bin[x];
    }
    bin[cur]=x;
    return x;
}

void init(){
    edge.clear();
    for(int i=0;i<=n;i++){
        bin[i]=i;
    }
}

int main(){ 
    // freopen("in.txt", "r", stdin);
    // freopen("out.txt", "w", stdout);
    while(scanf("%d",&n)!=EOF){
        init();
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&x);
                if(i==j) continue;
                edge.push_back(Node(i,j,x));
            }
        }
        int res=0;
        sort(edge.begin(),edge.end());
        for(int i=0;i<edge.size();i++){
            int fx=findx(edge[i].u);
            int fy=findx(edge[i].v);
            if(fx!=fy){
                res+=edge[i].val;
                bin[fx]=fy;
            }
        }
        printf("%d\n",res);
    }
    return 0;
}

 

poj 1258 Agri-Net

标签:namespace   ssi   any   last   hat   class   sha   put   int   

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/7221541.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!