码迷,mamicode.com
首页 > Web开发 > 详细

Wireless Network 并查集

时间:2017-07-23 13:38:05      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:operation   job   contains   reg   mmu   compute   expected   can   lan   

Wireless Network

 

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

并查集,每修好一台电脑,枚举一遍其他n-1点,<=d且修好的合并。距离的判断稍坑。。斜方向需要算直线距离。

#include<stdio.h>
#include<math.h>
#include<stdlib.h>
int f[1005],xx[1005],yy[1005],re[1005];
double d;
int find(int x)
{
    return f[x]==x?x:f[x]=find(f[x]);
}
void join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy) f[fy]=fx;
}
int dis(int x,int i)
{
    double y;
    y=sqrt(abs(xx[x]-xx[i])*abs(xx[x]-xx[i])+abs(yy[x]-yy[i])*abs(yy[x]-yy[i]));
    if(d>=y) return 1;
    return 0;
}

int main()
{
    int n,x,y,i;
    char s[5];
    scanf("%d%lf",&n,&d);
    for(i=1;i<=n;i++){
        scanf("%d%d",&x,&y);
        xx[i]=x;
        yy[i]=y;
        f[i]=i;
    }
    getchar();
    while(~scanf("%s",s)){
        if(s[0]==O){
            scanf("%d",&x);
            re[x]=1;
            for(i=1;i<=n;i++){ 
                if(re[i]==1&&dis(x,i)){
                    join(x,i);
                } 
            }
        }
        else{
            scanf("%d%d",&x,&y);
            if(re[x]==1&&re[y]==1&&find(x)==find(y)) printf("SUCCESS\n");
            else printf("FAIL\n");
        }
        getchar();
    }
    return 0;
}

 

Wireless Network 并查集

标签:operation   job   contains   reg   mmu   compute   expected   can   lan   

原文地址:http://www.cnblogs.com/yzm10/p/7224147.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!