码迷,mamicode.com
首页 > Web开发 > 详细

POJ - 2236Wireless Network-并查集

时间:2017-07-23 16:44:30      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:url   word   通信   nes   tracking   idg   back   pad   set   

POJ - 2236
Time Limit: 10000MS   Memory Limit: 65536KB   64bit IO Format: %I64d & %I64u

 Status

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS
首先要看懂题目的意思。首先要进行通信,首先你的电脑必须已经修好,否则是不可以通信的,并且通信时距离在一定范围内才可以实现
/*
Author: 2486
Memory: 380 KB		Time: 3063 MS
Language: G++		Result: Accepted
*/
#include <cstring>
#include <string>
#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=10000+5;
int N,d;
char op[10];
int par[maxn],ranks[maxn];
bool vis[maxn];//代表着是否已经修复了电脑,电脑是否正常
struct co {
    int x,y;
} coh[maxn];
void init(int sizes) {
    for(int i=0; i<=sizes; i++) {
        par[i]=i;
        ranks[i]=1;
    }
}
int find(int x) {
    return par[x]==x?x:par[x]=find(par[x]);
}
bool same(int x,int y) {
    return find(x)==find(y);
}
bool judge(int x,int y) {
    return pow((coh[x].x-coh[y].x),2.0)+pow((coh[x].y-coh[y].y),2.0)<=pow(d,2.0);//推断距离是否符合条件
}
void unite(int x,int y) {
    x=find(x);
    y=find(y);
    if(x==y)return ;
    if(ranks[x]>ranks[y]) {
        par[y]=x;
    } else {
        par[x]=y;
        if(ranks[x]==ranks[y])ranks[x]++;
    }
}
int main() {
    int c,e;
    scanf("%d%d",&N,&d);
    init(N);
    memset(vis,false,sizeof(vis));
    for(int i=1; i<=N; i++) {
        scanf("%d%d",&coh[i].x,&coh[i].y);
    }
    while(~scanf("%s",op)) {
        if(op[0]=='O') {
            scanf("%d",&c);
            vis[c]=true;
            for(int i=1; i<=N; i++) {
                if(vis[i]&&judge(c,i)) {//与其它的电脑进行联系的前提是他们是好的,假设不好就连接不上
                    unite(c,i);
                }
            }
        } else {
            scanf("%d%d",&c,&e);
            if(vis[c]&&vis[e]&&same(c,e)) {//是否通信。要看电脑是否已经修复完毕
                printf("SUCCESS\n");
            } else printf("FAIL\n");
        }
    }
    return 0;
}


POJ - 2236Wireless Network-并查集

标签:url   word   通信   nes   tracking   idg   back   pad   set   

原文地址:http://www.cnblogs.com/zhchoutai/p/7224779.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!