码迷,mamicode.com
首页 > 编程语言 > 详细

Let the Balloon Rise map一个数组

时间:2017-07-23 16:45:25      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:cst   ase   span   next   contest   distrib   this   hat   ber   

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges‘ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

InputInput contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
OutputFor each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink

代码:

#include <iostream>
#include <cstdio>
#include <queue>
#include <map>
using namespace std;

int main()
{
    int n;
    string a,max="a";
    map<string,int> b;
    while(scanf("%d",&n)&&n)
    {
        b[max]=0;
        for(int i=1;i<=n;i++)
        {
            cin>>a;
            b[a]++;
            if(b[a]>b[max])max=a;
        }
        cout<<max<<endl;
    }
}

 

Let the Balloon Rise map一个数组

标签:cst   ase   span   next   contest   distrib   this   hat   ber   

原文地址:http://www.cnblogs.com/8023spz/p/7224910.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!