码迷,mamicode.com
首页 > 移动开发 > 详细

HDU 1017 A Mathematical Curiosity (枚举水题)

时间:2017-07-26 13:44:55      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:ini   pairs   ++   man   test   osi   scanf   parent   inpu   

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
1 10 1 20 3 30 4 0 0
 

Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
 
  WA点在于格式控制!!

!细致审题

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
	int a,b,mod,n,m,t,number,ans;
	scanf("%d",&t);
	while(t--) {
		number=0;
		while(scanf("%d%d",&n,&m)!=EOF){
			if(n==0 && m==0) break;
			ans=0;
			for(a=1;a<n;a++) {
				for(b=a+1;b<n;b++) {
					if((a*a+b*b+m)%(a*b)==0) ans++;
				}
			}
			printf("Case %d: %d\n",++number,ans);
		}
		if(t) printf("\n");
	}
	return 0;
}


HDU 1017 A Mathematical Curiosity (枚举水题)

标签:ini   pairs   ++   man   test   osi   scanf   parent   inpu   

原文地址:http://www.cnblogs.com/clnchanpin/p/7238972.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!