码迷,mamicode.com
首页 > Web开发 > 详细

Network Saboteur (DFS暴力枚举)

时间:2017-07-27 10:37:00      阅读:344      评论:0      收藏:0      [点我收藏+]

标签:single   algo   mat   careful   sed   repr   ring   compose   dmi   

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts. 
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks. 
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him. 
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000). 
Output file must contain a single integer -- the maximum traffic between the subnetworks. 

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<stack>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<algorithm>
#include<functional>
#include<sstream>
using namespace std;
const int Max = 21;
const bool A = true;
const bool B = false;
int n, map[Max][Max], ans = 0;
bool Set[Max];
void dfs(int dep, int sum)
{
    if (dep > n) {
        if (sum > ans)
            ans = sum;
        return;
    }
    int m;
    m = 0;
    Set[dep] = A;
    for (int i = 1; i <= dep; i++)
        if (Set[i] == B)
            m += map[i][dep];
    dfs(dep + 1, sum + m);

    m = 0;
    Set[dep] = B;
    for (int i = 1; i <= dep; i++)
        if (Set[i] == A)
            m += map[i][dep];
    dfs(dep + 1, sum + m);
}

int main()
{
    cin >> n;
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++)
            cin >> map[i][j];
    dfs(1, 0);
    cout << ans << endl;
    return 0;
}

 

Network Saboteur (DFS暴力枚举)

标签:single   algo   mat   careful   sed   repr   ring   compose   dmi   

原文地址:http://www.cnblogs.com/edych/p/7243176.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!