码迷,mamicode.com
首页 > 编程语言 > 详细

16-最少回文数组

时间:2017-08-25 21:44:14      阅读:420      评论:0      收藏:0      [点我收藏+]

标签:others   example   描述   ++   war   read   ini   using   his   

                     

                Splits the string

                    时间限制:1000 ms  |  内存限制:65535 KB
                          难度:3
描述
Hrdv is interested in a string,especially the palindrome string.So he wants some palindrome string.

A sequence of characters is a palindrome if it is the same written forwards and backwards. For example, ‘abeba‘ is a palindrome, but ‘abcd‘ is not.

A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, (‘race‘, ‘car‘) is a partition of ‘racecar‘ into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

‘racecar‘ is already a palindrome, therefore it can be partitioned into one group.
‘fastcar‘ does not contain any non-trivial palindromes, so it must be partitioned as (‘f‘, ‘a‘, ‘s‘, ‘t‘, ‘c‘, ‘a‘, ‘r‘).
‘aaadbccb‘ can be partitioned as (‘aaa‘, ‘d‘, ‘bccb‘).
Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

输入
Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.
输出
For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.
样例输入
racecar
fastcar
aaadbccb
样例输出
1
7
3
上传者
TC_胡仁东
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int dp[1005];
char a[1005];

int judge(int i, int j){

//    while(a[i] == a[j]){
//        if(i == j)
//            break;
//        i++;
//        if(i == j)
//            break;
//        j--;
//        if(i == j)
//            break;
//    }
//    if(i == j && a[i] == a[j])
//        return 1;
//    else
//        return 0;
    //上面判断回文太麻烦了
    int mid = (i + j) >> 1;
    int m = i;
    for(int i; i <= mid; i++){
        if(a[i] != a[j - i + m])  //注意j - i时要加上数组片段传来的起点.
            return 0;
    }
    return 1;
}

int main(){
    while(~scanf("%s", a + 1)){
        int len = strlen(a + 1);
        for(int i = 1; i <= len; i++){
            dp[i] = i;
            for(int j = 1; j <= i; j++){
                if(a[i] == a[j] && judge(j, i)){        //dp[i]表示的是0到i的最少回文串数
                    dp[i] = min(dp[i], dp[j - 1] + 1);  //j从是从0开始扫描到i如果发现j到i是回文,
                                                        //则j到i为一个回文串,就可以得到这个递推关系
                }
            }
        }    
        printf("%d\n", dp[len]);     
    }
    return 0;
}

16-最少回文数组

标签:others   example   描述   ++   war   read   ini   using   his   

原文地址:http://www.cnblogs.com/zhumengdexiaobai/p/7429674.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!