码迷,mamicode.com
首页 > 数据库 > 详细

HDU 1397 Goldbach's Conjecture(素数打表)

时间:2014-09-09 18:26:39      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:hdu   prime   素数   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1397


Problem Description
Goldbach‘s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2. 
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 
Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 
Output
Each output line should contain an integer number. No other characters should appear in the output.
 
Sample Input
6 10 12 0
 
Sample Output
1 2 1
 
Source


题意:

给出一个n,找出两个素数a,b且a+b=n;问有多少对这样的素数!

代码如下:

#include <cstdio>
int pri[40017];
int main()
{
    for(int i = 2; i*i < 32768; i++)
    {
        if(!pri[i])
        {
            for(int j = i; j*i < 32768; j++)
            {
                pri[j*i] = 1;
            }
        }
    }
    int n;
    while(scanf("%d",&n) && n)
    {
        int k = 0;
        for(int i = 2; i <= n/2; i++)
        {
            if(!pri[i] && !pri[n-i])
                k++;
        }
        printf("%d\n",k);
    }
    return 0;
}


HDU 1397 Goldbach's Conjecture(素数打表)

标签:hdu   prime   素数   

原文地址:http://blog.csdn.net/u012860063/article/details/39157633

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!