码迷,mamicode.com
首页 > 编程语言 > 详细

问题 F: 例题6-1 逆序输出数组元素

时间:2017-10-29 20:21:25      阅读:275      评论:0      收藏:0      [点我收藏+]

标签:get   blank   clu   problems   title   temp   输入   gre   空格   

问题 F: 例题6-1 逆序输出数组元素

时间限制: 1 Sec  内存限制: 12 MB
献花: 155  解决: 137
[献花][花圈][TK题库]

题目描述

从键盘上输入10个整数,存储在一个长度为10的整型数组中,要求将输入的10个数逆序输出。

如输入为:0,1,2,3,4,5,6,7,8,9 输出为9,8,7,6,5,4,3,2,1,0

 

输入

10个整数,以空格分隔

输出

将输入的10个整数逆序输出,每个数占一行。

样例输入

0 1 2 3 4 5 6 7 8 9

样例输出

9
8
7
6
5
4
3
2
1
0

参考代码:

#include<stdio.h>
int main(){
  int a[10];
  for(int i=0;i<10;i++){
    scanf("%d",&a[i]);
  }
  for(int i=0;i<5;i++){
    int temp=a[i];
    a[i]=a[9-i];
    a[9-i]=temp;
  }
  for(int i=0;i<10;i++){
    printf("%d\n",a[i]);
  }
  return 0;
}

 

问题 F: 例题6-1 逆序输出数组元素

标签:get   blank   clu   problems   title   temp   输入   gre   空格   

原文地址:http://www.cnblogs.com/zhhjthing/p/7750869.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!