码迷,mamicode.com
首页 > Web开发 > 详细

ZOJ1372 POJ 1287 Networking 网络设计 Kruskal算法

时间:2014-09-19 23:58:56      阅读:540      评论:0      收藏:0      [点我收藏+]

标签:acm   poj   zoj   kruskal   

题目链接:ZOJ1372 POJ 1287 Networking 网络设计

Networking

Time Limit: 2 Seconds      Memory Limit: 65536 KB

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.

Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.


Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.

The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.


Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.


Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0


Sample Output

0
17
16
26


题意:

设计一个网络连接某个区域的一些点,以及这些地点之间可以用网线连接的线路。对每条线路,给定了连接这两个地方所需网线的长度。注意,两个地点之间的线路可能有多条。假定,给定的线路可以直接或间接地连接该地区中的所有地点。试为这个地区设计一个网络系统,使得该地区所有地点都可以连接,并且使用的网线长度最短。

分析:

最小生成树,采用Kruskal算法能够规避重边的问题,因为边是按照长度从小到大排序,因而当选择了长度短的边后便不会选择长度更长的重边。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define maxm 1300
int parent[55];
int ans, m;
struct edge
{
    int u, v, w;
}EG[maxm];
bool cmp(edge a, edge b)
{
    return a.w < b.w;
}
int Find(int x)
{
    if(parent[x] == -1) return x;
    return Find(parent[x]);
}
void Kruskal()
{
    memset(parent, -1, sizeof(parent));
    ans = 0;
    sort(EG, EG+m, cmp);
    for(int i = 0; i < m; i++)
    {
        int t1 = Find(EG[i].u), t2 = Find(EG[i].v);
        if(t1 != t2)
        {
            ans += EG[i].w;
            parent[t1] = t2;
        }
    }
}
int main()
{
    int n;
    while(scanf("%d", &n), n)
    {
        scanf("%d", &m);
        for(int i = 0; i < m; i++)
            scanf("%d%d%d", &EG[i].u, &EG[i].v, &EG[i].w);
        Kruskal();
        printf("%d\n", ans);
    }
    return 0;
}




ZOJ1372 POJ 1287 Networking 网络设计 Kruskal算法

标签:acm   poj   zoj   kruskal   

原文地址:http://blog.csdn.net/u011439796/article/details/39404221

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!