码迷,mamicode.com
首页 > 编程语言 > 详细

python3 升级 pip9.0.1 到pip-9.0.3

时间:2018-03-27 01:52:28      阅读:1211      评论:0      收藏:0      [点我收藏+]

标签:man   blog   解决办法   更新   from   pac   site   however   post   

python -m pip install --upgrade pip

python3.5 升级 pip-9.0.3报错

You are using pip version 9.0.1, however version 9.0.3 is available.
You should consider upgrading via the ‘python -m pip install --upgrade pip‘ command.

看版本 

pip -V
pip 9.0.1 from f:\python\lib\site-packages\pip-9.0.1-py3.5.egg (python 3.5)

当你执行python -m pip install --upgrade pip

他会告诉你 Requirement already up-to-date: pip in f:\python\lib\site-packages

再看版

pip -V
pip 9.0.1 from f:\python\lib\site-packages\pip-9.0.1-py3.5.egg (python 3.5)

为什么还是pip 9.0.1呢

解决办法:

找到 f:\python\lib\site-packages 删除pip-9.0.3.dist-info

然后再更新 (使用管理员身份)

python -m pip install --upgrade pip

C:\WINDOWS\system32>pip -V
pip 9.0.3 from f:\python\lib\site-packages (python 3.5)

如果不行 就使用whl安装

pip install .\pip-9.0.3-py2.py3-none-any.whl

 

python3 升级 pip9.0.1 到pip-9.0.3

标签:man   blog   解决办法   更新   from   pac   site   however   post   

原文地址:https://www.cnblogs.com/wtcl/p/8654876.html

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!