码迷,mamicode.com
首页 > 数据库 > 详细

POJ 2262 Goldbach's Conjecture

时间:2014-05-13 23:48:45      阅读:511      评论:0      收藏:0      [点我收藏+]

标签:poj

Goldbach‘s Conjecture
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 36797   Accepted: 14102

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach‘s conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach‘s conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


/*****************************************************/
/****    POJ 2262 Goldbach‘s Conjecture         ******/
/****    Wangguoliang   @Greenday               ******/
/****    2014-5-12                              ******/

//此题很水但是却超时了两次,都是一些小的细节,感觉主要是我的基本功还是不扎实
//上次省赛选拔就能跪在了while(1)上。。。当时自己彻底无语了 
#include<stdio.h>

int Jprime(int n)//判断是否为素数 
{
   int i;
   for(i=2;i*i<=n;i++)//刚开始用的是i<=n/2超时两次,汗。。。 
   if(n%i==0)
    return 0;
   return 1;    
}

int main()
{
   int n,i,j;
   int flag;
   while(scanf("%d",&n),n)
   {
     flag=0;
     //int maxi=0,maxj=0;
     for(i=3;i<=n/2;i+=2)
      {
         j=n-i;
         if(Jprime(j)&&Jprime(i))//如果ij都为素数,则打印输出 
           {
             flag=1;
             /*if(j-i>maxj-maxi)  //求出j-i值最大的一组数据 
             {
              maxi=i;
              maxj=j; 
             }  */        
             printf("%d = %d + %d\n",n,i,j);//第一次符合的数据肯定是差值最大的,此时就直接break; 
             break;
           }     
      }              
      if(!flag)
              printf("Goldbach‘s conjecture is wrong.\n");              
   }  
   return 0; 
}


POJ 2262 Goldbach's Conjecture,布布扣,bubuko.com

POJ 2262 Goldbach's Conjecture

标签:poj

原文地址:http://blog.csdn.net/zzucsliang/article/details/25644775

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!