码迷,mamicode.com
首页 > 编程语言 > 详细

POJ #3041 Asteroids 3041 二分图最小覆盖 最大匹配 匈牙利算法

时间:2018-04-15 11:40:52      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:cst   cross   ati   nbsp   none   匈牙利   one   一个   des   

Description


 

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 
Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

 

思路


 

  这道题的建模很经典,我们将每一行看作是一个X结点,每一列看作是一个Y结点,每个目标对应一条边,则击毁所有目标且发射次数最少就意味着选取最少的点,使得任意一条边至少有一个端点被选中。而这个对应着二分图最小覆盖概念的定义,由定理知二分图最少点覆盖数 = 最大匹配数,所以利用匈牙利算法解决该题。

  AC代码如下:

技术分享图片
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>

const int maxn = 510;
const int maxk = 10010;
int n,k;
int line[maxn][maxn];
bool used[maxn];
int next[maxn];

bool find (int x) {
    for (int i = 1; i <= n; i++) {
        if (line[x][i] &&!used[i]) {
            used[i] = true;
            if (!next[i] || find(next[i])) {
                next[i] = x;
                return true;
            }
        }
    }
    return false;
}

int match() {
    int sum = 0;
    for (int i = 1; i <= n; i++) {
        memset(used, 0, sizeof(used));
        if (find(i)) sum++;
    }
    return sum;
}

int main(void) {
    int u,v;
    while(~scanf("%d%d", &n, &k)) {
        memset(line, 0, sizeof(line));
        memset(next, 0, sizeof(next));
        while(k--) {
            scanf("%d%d", &u, &v);
            line[u][v] = 1;
        }
        printf("%d\n", match());
    }
    return 0;
}
View Code

 

  

POJ #3041 Asteroids 3041 二分图最小覆盖 最大匹配 匈牙利算法

标签:cst   cross   ati   nbsp   none   匈牙利   one   一个   des   

原文地址:https://www.cnblogs.com/Bw98blogs/p/8836831.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!