码迷,mamicode.com
首页 > 编程语言 > 详细

hdu4280 Island Transport(最大流Dinic数组模拟邻接连边)

时间:2018-04-16 23:47:30      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:line   ted   empty   pac   close   strong   number   main   java   

Island Transport

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 10716    Accepted Submission(s): 3430


Problem Description
  In the vast waters far far away, there are many islands. People are living on the islands, and all the transport among the islands relies on the ships.
  You have a transportation company there. Some routes are opened for passengers. Each route is a straight line connecting two different islands, and it is bidirectional. Within an hour, a route can transport a certain number of passengers in one direction. For safety, no two routes are cross or overlap and no routes will pass an island except the departing island and the arriving island. Each island can be treated as a point on the XY plane coordinate system. X coordinate increase from west to east, and Y coordinate increase from south to north.
  The transport capacity is important to you. Suppose many passengers depart from the westernmost island and would like to arrive at the easternmost island, the maximum number of passengers arrive at the latter within every hour is the transport capacity. Please calculate it.
 

 

Input
  The first line contains one integer T (1<=T<=20), the number of test cases.
  Then T test cases follow. The first line of each test case contains two integers N and M (2<=N,M<=100000), the number of islands and the number of routes. Islands are number from 1 to N.
  Then N lines follow. Each line contain two integers, the X and Y coordinate of an island. The K-th line in the N lines describes the island K. The absolute values of all the coordinates are no more than 100000.
  Then M lines follow. Each line contains three integers I1, I2 (1<=I1,I2<=N) and C (1<=C<=10000) . It means there is a route connecting island I1 and island I2, and it can transport C passengers in one direction within an hour.
  It is guaranteed that the routes obey the rules described above. There is only one island is westernmost and only one island is easternmost. No two islands would have the same coordinates. Each island can go to any other island by the routes.
 

 

Output
  For each test case, output an integer in one line, the transport capacity.
 

 

Sample Input
2
5 7
3 3
3 0
3 1
0 0
4 5
1 3 3
2 3 4
2 4 3
1 5 6
4 5 3
1 4 4
3 4 2
6 7
-1 -1
0 1
0 2
1 0
1 1
2 3
1 2 1
2 3 6
4 5 5
5 6 3
1 4 6
2 5 5
3 6 4
Sample Output
9
6
 
分析:比较裸的最大流,先找起点(X坐标最小)和终点(X坐标最大),
用数组模拟邻接链表记录图的边,跑一遍Dinic算出最大流。
用G++提交8330MS,用C++提交Time Limit Exceeded......
 
技术分享图片
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define INF 1000000007
using namespace std;
int N,M,cnt,T,S;//T是终点 
struct Node{
    int t,c;
}edge[500000];
int head[100010],next1[500000];
int dis[100010];

void add(int s,int t,int c)
{
    edge[cnt].t=t;
    edge[cnt].c=c;
    next1[cnt]=head[s];
    head[s]=cnt++;
}

int bfs()
{
    memset(dis,-1,sizeof(dis));
    dis[S]=0;
    queue<int> q;
    q.push(S);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        int k=head[u];
        while(k!=-1)
        {
            int v=edge[k].t;
            if(dis[v]==-1&&edge[k].c>0)
            {
                dis[v]=dis[u]+1;
                q.push(v);
            }
            k=next1[k];
        }
    }
    if(dis[T]>0) return 1;
    return 0;
}

int dfs(int cur,int m)
{
    if(cur==T) return m;
    int res=0,f,k=head[cur];
    while(k!=-1)
    {
        if(dis[edge[k].t]==dis[cur]+1&&edge[k].c>0&&(f=dfs(edge[k].t,min(m,edge[k].c))))
        {
            edge[k].c-=f;
            edge[k^1].c+=f;
            res+=f;
            m-=f;
            if(!m) break;
        }
        k=next1[k];
    }
    if(!res) dis[cur]=-2;
    return res;
}

int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        memset(head,-1,sizeof(head));
        scanf("%d%d",&N,&M);
        int sx=INF,tx=-INF;//起点S和终点T的x坐标 
        cnt=S=T=0;
        for(int i=1;i<=N;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(sx>=x) {sx=x;S=i;}
            if(tx<=x) {tx=x;T=i;}
        }
        for(int i=0;i<M;i++)
        {
            int s,t,c;
            scanf("%d%d%d",&s,&t,&c);
            add(s,t,c);
            add(t,s,c);
        }
        int ans=0,res;
        while(bfs())
            while(res=dfs(S,INF)) ans+=res;
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

 
 
 
 
 
 
 
 
 
 
 

hdu4280 Island Transport(最大流Dinic数组模拟邻接连边)

标签:line   ted   empty   pac   close   strong   number   main   java   

原文地址:https://www.cnblogs.com/ACRykl/p/8859076.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!