码迷,mamicode.com
首页 > Web开发 > 详细

poj 2349 Arctic Network(prime)

时间:2018-05-05 21:45:55      阅读:255      评论:0      收藏:0      [点我收藏+]

标签:rtm   建立   ssi   rect   定义   sts   algo   contain   contains   

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 25165   Accepted: 7751

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel.
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts.

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13
题意:国防部(DND)要用无线网络连接北部几个哨所。有两种不同的通信技术被用于建立网络:每一个哨所有一个无线电收发器,一些哨所将有一个卫星频道。 
   任何两个有卫星信道的哨所可以通过卫星进行通信,而不管他们的位置。同时,当两个哨所之间的距离不超过D时可以通过无线电通讯,D取决于对收发器的功率。功率越大,D也越大,但成本更高。出于采购和维修的方便,所有哨所的收发器必须是相同的;也就是说,D值对每一个哨所相同。 
你的任务是确定收发器的D的最小值。每对哨所间至少要有一条通信线路(直接或间接)。
 
思路:有 m 个哨所需要m-1条边连接,s颗卫星可以代替s-1条边,用卫星代替最长的边
#include <iostream>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
#define N 510

const double M=1e12;//定义一个大值  
int p,s;

struct dot //哨站结点 
{
	double x,y;
}d[N];

double map[N][N];
double rank[N],dst[N];//rank放最小生成树的各边长,dst放各点到MST的最近距离 
int vis[N];

double dist(int i,int j)//求两点距离 
{
	double x,y;
	x=d[i].x-d[j].x;
	y=d[i].y-d[j].y;
	
	return sqrt(x*x+y*y);
}

void init()
{
	int i,j;
	
	memset(map,0,sizeof(M));
	for (i=0;i<p;i++)//初始化图 
	{
		for (j=0;j<p;j++)
		{
			if (i==j)
			{
				map[i][j]=0;
			}
			
			else
			{
				map[i][j]=map[j][i]=dist(i,j);
			}
		}
	}
	
	memset(vis,0,sizeof(vis));
	memset(dst,0,sizeof(dst));
}

//bool cmp(int i,int j)
//{
//	if (rank[i]<rank[j])
//	{
//		return true;
//	}
//	return false;
//}

void findans()
{
	int i,j;
	sort(rank,rank+p-1);//按增序排列,注意排序范围为rank+p-1,因为MST只有p-1条边 
	printf("%.2f\n",rank[p-s-1]);// (p-1)-(s-1)-1,因为序号从0开始 
	
//	for (i=0;i<p;i++)
//	{
//		for (j=0;j<p;j++)
//		{
//			printf("%10.2f",map[i][j]);
//		}
//		printf("\n");
//	}
//	printf("\n");
//	for (i=0;i<p-1;i++)
//	{
//		printf("%10.2f",rank[i]);
//	}
}

void prime()
{
	int cnt=0,k,j,point,i;
	double min;
	
	vis[0]=1;//把0点放入MST 
	for (i=0;i<p;i++)//初始化dst 
	{
		dst[i]=map[i][0];
	}
	
	for (i=1;i<p;i++)//找距MST最近的点 
	{
		min=M;
		for (j=0;j<p;j++)
		{
			if (vis[j]==0&&min>dst[j])
			{
				min=dst[j];
				point=j;
			}
		}
		
//		if (min==M)
//		{
//			break;
//		}
		
		vis[point]=1;
		rank[cnt++]=min;
		
		for (k=0;k<p;k++)//更新各点到MST的最小距离 
		{
			if (vis[k]==0&&dst[k]>map[k][point])
			{
				dst[k]=map[k][point];
			}
		}
	}
	findans();
}

int main()
{
	int i,n,j;
	double x,y;
	
	scanf("%d",&n);
	for (i=0;i<n;i++)
	{
		scanf("%d%d",&s,&p);
		
		for (j=0;j<p;j++)
		{
			scanf("%lf%lf",&d[j].x,&d[j].y);
		}
		
		init();
		prime();
	}
	
	return 0;
} 

 

poj 2349 Arctic Network(prime)

标签:rtm   建立   ssi   rect   定义   sts   algo   contain   contains   

原文地址:https://www.cnblogs.com/hemeiwolong/p/8996192.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!