码迷,mamicode.com
首页 > 编程语言 > 详细

C语言:指针实现输出梯形字符串

时间:2018-05-08 19:23:46      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:int   title   compute   eof   输入   clu   class   字符   sizeof   

用指针实现,实现过程无需将子串复制到一个新的字符串中。(10分)

题目内容:

用指针实现,实现过程无需将子串复制到一个新的字符串中。

 

输入格式:

字符串

 

输出格式:

子串

 

输入样例:

computer

 

输出样例:

computer

omputer

mputer

puter

uter

ter

er

r

 

 

code

#include "stdio.h"
int main()
{
	char s[30];
	char * p =s;
    scanf("%s",p);
    int i;
	for (i=0;i<sizeof(p);i++)
	{
		printf("%s\n",p+i );
	}
	return 0;	
}

  

C语言:指针实现输出梯形字符串

标签:int   title   compute   eof   输入   clu   class   字符   sizeof   

原文地址:https://www.cnblogs.com/songqingbo/p/9009858.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!