码迷,mamicode.com
首页 > Windows程序 > 详细

POJ 3686 The Windy's

时间:2014-09-26 19:45:28      阅读:354      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   strong   for   


拆点+最小费用最大流:

将工厂拆点,表示再第j个工厂倒数第k个生产则第i个玩具到(j,k)工厂的费用为 k*t[i][j]



The Windy‘s
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 4066   Accepted: 1746

Description

The Windy‘s is a world famous toy factory that owns M top-class workshop to make toys. This year the manager receives N orders for toys. The manager knows that every order will take different amount of hours in different workshops. More precisely, the i-th order will take Zij hours if the toys are making in the j-th workshop. Moreover, each order‘s work must be wholly completed in the same workshop. And a workshop can not switch to another order until it has finished the previous one. The switch does not cost any time.

The manager wants to minimize the average of the finishing time of the N orders. Can you help him?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N and M (1 ≤ N,M ≤ 50).
The next N lines each contain M integers, describing the matrix Zij (1 ≤ Zij ≤ 100,000) There is a blank line before each test case.

Output

For each test case output the answer on a single line. The result should be rounded to six decimal places.

Sample Input

3

3 4
100 100 100 1
99 99 99 1
98 98 98 1

3 4
1 100 100 100
99 1 99 99
98 98 1 98

3 4
1 100 100 100
1 99 99 99
98 1 98 98

Sample Output

2.000000
1.000000
1.333333

Source






#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

const int maxn=5000;
const int INF=0x3f3f3f3f;

struct Edge
{
    int to,next,cap,flow,cost;
} edge[1500000];

int Adj[maxn],Size,N;

void init()
{
    Size=0;
    memset(Adj,-1,sizeof(Adj));
}

void addedge(int u,int v,int cap,int cost)
{
    edge[Size].to=v;
    edge[Size].next=Adj[u];
    edge[Size].cost=cost;
    edge[Size].cap=cap;
    edge[Size].flow=0;
    Adj[u]=Size++;
}

void Add_Edge(int u,int v,int cap,int cost)
{
    addedge(u,v,cap,cost);
    addedge(v,u,0,-cost);
}

int dist[maxn],vis[maxn],pre[maxn];

bool spfa(int s,int t)
{
    queue<int> q;
    for(int i=0; i<N; i++)
    {
        dist[i]=INF;
        vis[i]=false;
        pre[i]=-1;
    }
    dist[s]=0;
    vis[s]=true;
    q.push(s);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=false;
        for(int i=Adj[u]; ~i; i=edge[i].next)
        {
            int v=edge[i].to;
            if(edge[i].cap>edge[i].flow&&
                    dist[v]>dist[u]+edge[i].cost)
            {
                dist[v]=dist[u]+edge[i].cost;
                pre[v]=i;
                if(!vis[v])
                {
                    vis[v]=true;
                    q.push(v);
                }
            }
        }
    }
    if(pre[t]==-1) return false;
    return true;
}

int MinCostMaxFlow(int s,int t,int& cost)
{
    int flow=0;
    cost=0;
    while(spfa(s,t))
    {
        int Min=INF;
        for(int i=pre[t]; ~i; i=pre[edge[i^1].to])
        {
            if(Min>edge[i].cap-edge[i].flow)
                Min=edge[i].cap-edge[i].flow;
        }
        for(int i=pre[t]; ~i; i=pre[edge[i^1].to])
        {
            edge[i].flow+=Min;
            edge[i^1].flow-=Min;
            cost+=edge[i].cost*Min;
        }
        flow+=Min;
    }
    return flow;
}

int n,m;
int tv[60][60];

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        init();
        scanf("%d%d",&n,&m);
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
                scanf("%d",&tv[i][j]);
        for(int i=1; i<=n; i++) ///i号玩具
        {
            Add_Edge(0,i,1,0);
            for(int j=1; j<=m; j++) ///m类工厂
                for(int k=1; k<=n; k++) ///倒数第K个加工
                {
                    Add_Edge(i,j*n+k,1,tv[i][j]*k);
                    if(i==1)    Add_Edge(j*n+k,(m+1)*n+1,1,0);
                }
        }
        N=(m+1)*n+2;
        int cost,flow;
        flow=MinCostMaxFlow(0,N-1,cost);
        printf("%.6lf\n",1.*cost/flow);
    }
    return 0;
}


POJ 3686 The Windy's

标签:des   style   http   color   io   os   ar   strong   for   

原文地址:http://blog.csdn.net/ck_boss/article/details/39581623

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!