码迷,mamicode.com
首页 > 编程语言 > 详细

【TOJ 5240】C++实验:虚函数

时间:2018-05-17 19:51:17      阅读:266      评论:0      收藏:0      [点我收藏+]

标签:ace   完成   delete   turn   c++实现   c++   提交   otto   clu   

描述

用C++实现一个形状类和矩形类,并完成求面积函数。

主函数里的代码已经给出,请补充完整,提交时请勿包含已经给出的代码。

int main()
{
	int w, h;
	while(cin>>w>>h)
	{
		Shape* p = new Rectangle(w, h);
		cout<<p->Area()<<endl;
		delete p;
	}
	return 0;
}

输入

输入数据有多组,每组占一行,每行两个正整数,分别表示矩形的长和宽。

输出

每组输出一个正整数,表示矩形面积。

样例输入

2 3
5 6

样例输出

6
30

#include<iostream>
using namespace std;
class Shape{
public:
    virtual int Area(){}
};
class Rectangle:public Shape{
public:
    int a,b;
    Rectangle(int a=0,int b=0):a(a),b(b){}
    int Area()
    {
        return a*b;
    }
};
int main()
{
    int w, h;
    while(cin>>w>>h)
    {
        Shape* p = new Rectangle(w, h);
        cout<<p->Area()<<endl;
        delete p;
    }
    return 0;
}

 

【TOJ 5240】C++实验:虚函数

标签:ace   完成   delete   turn   c++实现   c++   提交   otto   clu   

原文地址:https://www.cnblogs.com/kannyi/p/9052731.html

(0)
(1)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!