码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 5050 Divided Land(最大公约数Java)

时间:2014-09-27 23:57:10      阅读:223      评论:0      收藏:0      [点我收藏+]

标签:数学   hdu   java   进制   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5050


Problem Description
It’s time to fight the local despots and redistribute the land. There is a rectangular piece of land granted from the government, whose length and width are both in binary form. As the mayor, you must segment the land into multiple squares of equal size for the villagers. What are required is there must be no any waste and each single segmented square land has as large area as possible. The width of the segmented square land is also binary.
 

Input
The first line of the input is T (1 ≤ T ≤ 100), which stands for the number of test cases you need to solve.

Each case contains two binary number represents the length L and the width W of given land. (0 < L, W ≤ 21000)
 

Output
For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then one number means the largest width of land that can be divided from input data. And it will be show in binary. Do not have any useless number or space.
 

Sample Input
3 10 100 100 110 10010 1100
 

Sample Output
Case #1: 10 Case #2: 10 Case #3: 110
 

Source

PS:

思路很简单,就是把输入的二进制长和宽转化为十进制求一个GCD然后在转换为二进制输出即可,不过由于数据过大,需要用Java来实现,这里贴一发队友敲的Java;


代码如下:

import java.math.*;
import java.util.Scanner;
 
public class Main{
    public static BigInteger gcd(BigInteger a,BigInteger b)
    {
        if(b.equals(BigInteger.ZERO))
            return a;
        return gcd(b,a.mod(b));
    }
        public static void main(String[] args)
       {
                 Scanner input = new Scanner(System.in);
                 int t,i,j;
                 String s=null;
                 char str[];
                 BigInteger a,b;
                 t=input.nextInt();
                 for(i=1;i<=t;i++)
                 {
                     a=input.nextBigInteger(2);
                     b=input.nextBigInteger(2);
                     a=gcd(a,b);
                     System.out.println("Case #"+i+": "+a.toString(2));
                 }
       }
         
}


HDU 5050 Divided Land(最大公约数Java)

标签:数学   hdu   java   进制   

原文地址:http://blog.csdn.net/u012860063/article/details/39617905

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!