码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 2000 ASCII码排序

时间:2018-06-24 22:29:57      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:acm   tle   panel   sci   asd   while   output   script   char s   

http://acm.hdu.edu.cn/showproblem.php?pid=2000

 

Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
 
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
 
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
 
Sample Input
qwe
asd
zxc
 
Sample Output
e q w
a d s
c x z
 
代码:
#include <bits/stdc++.h>

using namespace std;

char s[111];
int main()
{
    while(scanf("%s",s)!=EOF)
    {
        int len = strlen(s);
        for(int i=0; i<len; i++)
        {
            for(int j=i; j>=1; j--)
            {
                if(s[j]<=s[j-1])
                    swap(s[j],s[j-1]);
            }
        }

        for(int i=0; i<len; i++)
        {
            if(i!=len-1)
                printf("%c ",s[i]);
            else
                printf("%c\n",s[i]);
        }
    }
    return 0;
}

  

HDU 2000 ASCII码排序

标签:acm   tle   panel   sci   asd   while   output   script   char s   

原文地址:https://www.cnblogs.com/zlrrrr/p/9221815.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!