码迷,mamicode.com
首页 > Web开发 > 详细

wamp 安装多版本php

时间:2018-07-12 18:10:31      阅读:12      评论:0      收藏:0      [点我收藏+]

标签:eve   双击   官网   多版本   info   server   ora   pac   使用   

背景

本人使用的是wamp2.2 x64版本  原来自带的php是5.3的版本,想新装一个php5.4以上的版本。从官网上已经找不到php5.6.36以下的版本了。

下载了最低的php5.6.36 x64 线程安全版本进行安装。鼓捣了半天都无法成功。百度得知wamp2.2不支持php5.6  只支持5.5以下的版本。

最后换了一个php5.4.8 成功绿了。

操作步骤

1、下载好php版本之后考到D:\wamp\bin\php下并改名

技术分享图片

2、从php5.3.10中将wampserver.conf拷贝到php5.4.8中,并在php5.4.8中将php.ini-development复制一份,重命名为phpForApache.ini

技术分享图片

3、打开phpForApache.ini 修改增加一行extension_dir = "D:\wamp\bin\php\php5.4.8\ext" 将扩展指向新版本的php

技术分享图片

4、右键退出wamp。然后双击打开wamp,然后发现wamp已经绿了。

 技术分享图片

 

要点

新版本的php中需要有php5apache2_2.dll这个文件,如果下载的php版本没有该文件,请重新下载。并且注意配置wampserver.conf中下图标记的位置。正常来说不用修改。

技术分享图片

 

wamp 安装多版本php

标签:eve   双击   官网   多版本   info   server   ora   pac   使用   

原文地址:https://www.cnblogs.com/CryOnMyShoulder/p/9300439.html

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!