码迷,mamicode.com
首页 > 数据库 > 详细

java.lang.UnsupportedClassVersionError: com/mysql/cj/jdbc/Driver : Unsupported major.minor version 5

时间:2018-07-18 14:01:17      阅读:44      评论:0      收藏:0      [点我收藏+]

标签:解决方案   基于   one   minor   jdbc   jdk8   jdb   mysql   java   

原因:
com/mysql/cj/jdbc/Driver是6.0版本的驱动,兼容JDK8环境,不兼容JDK7环境,在基于jdk7的tomcat中编译运行会出错,在基于jdk8的tomcat中编译运行则不会出错。

解决方案:
1、jdk7+老版5.0驱动com/mysql/jdbc/Driver
2、jdk8+新版6.0驱动com/mysql/cj/jdbc/Driver

java.lang.UnsupportedClassVersionError: com/mysql/cj/jdbc/Driver : Unsupported major.minor version 5

标签:解决方案   基于   one   minor   jdbc   jdk8   jdb   mysql   java   

原文地址:https://www.cnblogs.com/GH0522/p/9328416.html

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!