码迷,mamicode.com
首页 > 编程语言 > 详细

树状数组

时间:2018-07-18 19:10:05      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:NPU   nbsp   ted   html   enter   test   nat   cond   scan   

算法学习:http://www.cnblogs.com/George1994/p/7710886.html

题目链接:https://vjudge.net/contest/231316#problem/E

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
技术分享图片

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.
 
题目大意:求左下方有多少个点,包括左方和下方
个人思路:也没什么思路,就是用树状数组吧,第一次接触,有点难
看代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<math.h>
#include<algorithm>
#include<set>
#include<queue>
typedef long long ll;
using namespace std;
const ll mod=1e9+7;
const int maxn=15050;
const ll maxa=32050;
#define INF 0x3f3f3f3f3f3f
int a[maxn],c[maxa];
int lowbit(int x)
{
    return x&(-x);
}
int getsum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=c[x];
        x=x-lowbit(x);
    }
    return res;
}
void updata(int x)
{
    while(x<maxa)
    {
        c[x]++;
        x=x+lowbit(x);
    }
}
int main()
{
    int n,x,y;
    memset(a,0,sizeof(a));
    memset(c,0,sizeof(c));
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        cin>>x>>y;
        a[getsum(x+1)]++;
        updata(x+1);
    }
    for(int i=0;i<n;i++)
        cout<<a[i]<<endl;
    return 0;
}

 

树状数组

标签:NPU   nbsp   ted   html   enter   test   nat   cond   scan   

原文地址:https://www.cnblogs.com/caijiaming/p/9330795.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!