标签:逆序对 several c++ sed freopen ace == mina cout
题目描述
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
输入
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
输出
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
样例输入
5
9
1
0
5
4
3
1
2
3
0
样例输出
6
0
#include <bits/stdc++.h>
using namespace std;
const int maxn = 5e5 + 1000;
const int inf = 0x3f3f3f3f;
int s[maxn], t[maxn];
long long cnt = 0;
int n;
void merge(int l1, int r1, int l2, int r2) {
int k = 0;
while (l1 <= r1 && l2 <= r2) {
if (s[l2] < s[l1]) t[++k] = s[l2++], cnt += r1 - l1 + 1;
//若s[l2]小,则l1~r1都比a[j]要大,他们都会与a[j]构成逆序对
else t[++k] = s[l1++];
}
while (l1 <= r1) t[++k] = s[l1++];
while (l2 <= r2) t[++k] = s[l2++];
for (int i = k, j = r2; i >= 1; i--, j--) {//j的最终值不一定为1~r2
s[j] = t[i];
}
}
void mergesort(int l, int r) {
int mid = (l + r) / 2;
if (l < r) {
mergesort(l, mid);
mergesort(mid + 1, r);
merge(l, mid, mid + 1, r);
}
}
int main() {
freopen("input.txt", "r", stdin);
while (cin >> n) {
cnt = 0;
if (n == 0)
break;
for (int i = 1; i <= n; i++)
cin >> s[i];
mergesort(1, n);
cout << cnt << endl;
}
return 0;
}
Ultra-QuickSort (归并排序,逆序数)
标签:逆序对 several c++ sed freopen ace == mina cout
原文地址:https://www.cnblogs.com/albert-biu/p/9348103.html