标签:main poj mini any sam eve clu length nec
题目描述
In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,
Ultra-QuickSort produces the output
0 1 4 5 9 .
Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
输入
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
输出
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
样例输入
5
9
1
0
5
4
3
1
2
3
0
样例输出
6
0
就是让你从小到大排序,每次只能交换相邻元素,求最小次数
#include <bits/stdc++.h>
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;
const int M=500005;
int L[M/2+2],R[M/2+2];
int t[M];
ll ans;
int n;
void mergearr(int A[],int left,int mid,int right)
{
int i=left,j=mid+1;
int k=left;
while(i<=mid&&j<=right)
{
if(A[i]<=A[j])
t[k++]=A[i++];
else{
t[k++]=A[j++];
ans+=mid-i+1;
}
}
while(i<=mid)
t[k++]=A[i++];
while(j<=right)
t[k++]=A[j++];
for(int i=left;i<=right;i++)
A[i]=t[i];
}
void mergeSort(int A[],int left,int right)
{
if(left<right)
{
int mid=(left+right)/2;
mergeSort(A,left,mid);
mergeSort(A,mid+1,right);
mergearr(A,left,mid,right);
}
}
int main()
{
int A[M];
int n,i;
while(scanf("%d",&n)&&n!=0)
{
ans=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&A[i]);
}
mergeSort(A,1,n);
printf("%lld\n",ans);
}
return 0;
}
【归并排序+逆序数】poj-2299 Ultra-QuickSort
标签:main poj mini any sam eve clu length nec
原文地址:https://www.cnblogs.com/Diliiiii/p/9389845.html