码迷,mamicode.com
首页 > Windows程序 > 详细

The following packages have unmet dependencies错误

时间:2018-08-23 11:25:18      阅读:1998      评论:0      收藏:0      [点我收藏+]

标签:方法   apt   ken   pre   str   The   strong   pac   解决方法   

当出现类似这类错误:

The following packages have unmet dependencies:
 python-dev : Depends: python (= 2.7.5-5ubuntu3) but 2.7.12-1~16.04 is to be installed
              Depends: libpython-dev (= 2.7.5-5ubuntu3) but it is not going to be installed
              Depends: python2.7-dev (>= 2.7.5-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

这是由于安装包的版本太新,其依赖包和旧版本冲突导致。

网上常见解决方法:apt-get -f install,but it doesn‘t work for me,或者说使用aptitude的,试了下很慢。

 

后来我把阿里源换回Ubuntu原生的源就可以安装了,因为阿里源的包太新。

The following packages have unmet dependencies错误

标签:方法   apt   ken   pre   str   The   strong   pac   解决方法   

原文地址:https://www.cnblogs.com/willaty/p/9522591.html

(1)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!