码迷,mamicode.com
首页 > 编程语言 > 详细

1003 Emergency(25 分)C语言版本(提问求解答)

时间:2018-09-02 11:55:37      阅读:265      评论:0      收藏:0      [点我收藏+]

标签:contains   ever   break   sep   tween   The   att   describes   follow   

1003 Emergency(25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (500) - the number of cities (and the cities are numbered from 0 to N?1), M - the number of roads, C?1?? and C?2?? - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c?1??, c?2?? and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C?1?? to C?2??.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C?1?? and C?2??, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4 

这篇我是根据其他前辈写的自己编写的,提交的时候现实只有一个正确,其余错误,希望大家帮我找一下我的错误。感谢感谢??
#include<stdio.h>
#include<math.h> 
#include <stdbool.h>
#define inf 9999999
int main(){
  int n,m,c1,c2,i,j;
  int num[510],weight[510],dis[510],w[510];//num路径条数 dis最短路径长 w最终队伍数目总和
  int e[510][510];
  bool visit[510];            //标记访问
  scanf("%d%d%d%d",&n,&m,&c1,&c2);
  for(i=0;i<n;i++)
    scanf("%d",&weight[i]);   //每个顶点的数量
  for(i=0;i<n;i++){
    for(j=0;j<n;j++){
      e[i][j]=inf;            //重置矩阵e顶点
    }
    dis[i]=inf;               //重置边
  }
  int a,b,c;
  for(i=0;i<m;i++){
    scanf("%d%d%d",&a,&b,&c);
    e[a][b]=e[b][a]=c;        //输入边
  }
  dis[c1]=0;
  w[c1]=weight[c1];
  num[c1]=1;
  for(i=0;i<n;i++){
    int u=-1,minn=inf;
    for(j=0;j<n;j++){
      if(visit[j]==false&&dis[j]<minn){
        u=j;minn=dis[j];
      }
    }
    if(u==-1) break;
    visit[u]=true;
    for(int v=0;v<n;v++){
      if(visit[v]==false&&e[u][v]!=inf){
        if(dis[v]+e[u][v]<dis[v]){
          dis[v]=e[u][v]+dis[v];
          num[v]=num[u];
          w[v]=w[u]+weight[v];
        }
        else if(dis[v]+e[u][v]==dis[v]){
          num[v]=num[u]+num[v];
          if(w[u]+weight[v]>w[v]){
            w[v]=w[u]+weight[v];
          }
        }
      }
    }
  }
  printf("%d %d",num[c2],w[c2]);
  return 0;
}

 





1003 Emergency(25 分)C语言版本(提问求解答)

标签:contains   ever   break   sep   tween   The   att   describes   follow   

原文地址:https://www.cnblogs.com/neojoker/p/9573242.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!