码迷,mamicode.com
首页 > Windows程序 > 详细

Windows Message Queue

时间:2014-10-08 09:31:55      阅读:309      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

D - Windows Message Queue
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There‘s only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there‘re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there‘s no message in the queue, output "EMPTY QUEUE!". There‘s no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <queue>
#include <algorithm>
using namespace std;

struct node
{
    char ss[30];
    int pp;
    int dd; //优先级
    int ff;
};

 priority_queue< node >q;
 map<int, int>ma;

bool operator<(const node &x, const node &y)//dingyi bijiao suanzi
{
    if(x.dd!= y.dd )
    {
        return x.dd > y.dd ;
    }
    return x.ff > y.ff ;
}


int main()
{
    char s[10];
    while(scanf("%s", s)!=EOF)
    {
         if(s[0]==‘G‘)
        {
            if(q.empty())
                printf("EMPTY QUEUE!\n");
            else
            {
                node outp;
                outp = q.top();
                q.pop();
                printf("%s %d\n", outp.ss, outp.pp );
            }
        }
        else
        {
            node newn;
            scanf("%s %d %d", newn.ss, &newn.pp, &newn.dd );
            newn.ff = ma[newn.dd]++;
            q.push(newn);
        }

    }
    return 0;
}

 

Windows Message Queue

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://www.cnblogs.com/yspworld/p/4010393.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!