码迷,mamicode.com
首页 > 编程语言 > 详细

(JAVA对进制的运算)A + B Again hdu2057 要复习

时间:2018-09-19 14:44:52      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:output   php   script   去除   upper   acea   panel   div   next   

(置顶,复习)A + B Again

链接:http://acm.hdu.edu.cn/showproblem.php?pid=2057

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 35905    Accepted Submission(s): 14614


Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
 

 

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
 

 

Output
For each test case,print the sum of A and B in hexadecimal in one line.
 

 

Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
 

 

Sample Output
0
2C
11
-2C
-90
 

 

Author
linle
 
注:
此题就是利用Long.parseLong()和Long.toHexString()的
replaceAll("\\+",""),是去除其中的‘+’,因为进制计算不支持带“+”的某一进制的数字字符串,‘-’可以,同时还需要判断正数负数,从而利用Long.toHexString()。
 
Java代码:
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner inScanner = new Scanner(System.in);
        while(inScanner.hasNext()) {
            long l = Long.parseLong(inScanner.next().replaceAll("\\+", ""),16)
                    + Long.parseLong(inScanner.next().replaceAll("\\+", ""),16);
            if(l<0) {
                System.out.println("-" + Long.toHexString(-l).toUpperCase());
            }
            else {
                System.out.println(Long.toHexString(l).toUpperCase());
            }
        }
    }
}

 

 

(JAVA对进制的运算)A + B Again hdu2057 要复习

标签:output   php   script   去除   upper   acea   panel   div   next   

原文地址:https://www.cnblogs.com/Weixu-Liu/p/9674229.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!