码迷,mamicode.com
首页 > 编程语言 > 详细

[算法竞赛入门经典]Kickdown ACM/ICPC NEERC 2004,UVa1587

时间:2018-09-22 21:19:35      阅读:292      评论:0      收藏:0      [点我收藏+]

标签:switch   ott   tee   get   single   leading   mob   wan   block   

Description

A research laboratory of a world-leading automobile company has received an order to create a special
transmission mechanism, which allows for incredibly efficient kickdown — an operation of switching to
lower gear. After several months of research engineers found that the most efficient solution requires
special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the
gears. Now they want to perform some experiments to prove their findings.
The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A
section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h.
Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom)
and one for the driven gear (with teeth at the top).
There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged
sections together. The sections are irregular but they may still be put together if shifted along each
other.
The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You
need to find the minimal length of the stripe which is enough for cutting both sections simultaneously.

Input

The input file contains several test cases, each of them as described below.
There are two lines in the input, each contains a string to describe a section. The first line describes
master section (teeth at the bottom) and the second line describes driven section (teeth at the top).
Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sections
can not be flipped or rotated.
Each string is non-empty and its length does not exceed 100.

Output

For each test case, write to the output a line containing a single integer number — the minimal length
of the stripe required to cut off given sections.

Sample Input

2112112112
2212112
12121212
21212121
2211221122
21212

Sample Output

10
8
15

Code

复杂版,模拟算法。此题用模拟来算的话会非常麻烦,要考虑很多边界问题

#include <stdio.h>
#include <string.h>
#define MAX 1000
char top[MAX];
char temp[MAX];
char down[MAX];

int main()
{
    while(~scanf("%s %s",top,down)){
        int len1 = (int)strlen(top),len2 = (int)strlen(down);
        int min = len1 + len2,max = len1 + len2,
                ss = len1,xl = len2;
        if(len1>len2){
            strcpy(temp,down); strcpy(down,top); strcpy(top,temp); ss = len2; xl = len1;
        }
        int j = 0;
        int jmp = 0;
        while(j < xl){                     
            int ok = 1;
            for(int x = j,y = 0;x < xl && y < ss;x ++,y ++){
                if((top[y] - ‘0‘)+(down[x] - ‘0‘) > 3){ ok = 0; break;}
            }
            if(ok) { min = xl; jmp = 1; break; }
            ++ j;
        }
        if(jmp)
            printf("%d\n",min);
        else{
            j = ss - 1;                    
            while(j > 0){            
                int sub = 0;
                for(int x = j,y = 0;x < ss && y < ss - j;x ++,y ++){
                    if((top[x] - ‘0‘) + (down[y] - ‘0‘) <= 3){
                        ++ sub;
                    }else{
                        sub = 0;
                        break;
                    }
                }
                int t = max - sub;
                if(t < min) min = t;
                -- j;
            }
            j = xl - ss + 1;
            while(j < xl){                     
                int sub = 0;
                for(int x = j,y = 0;x < xl && y < xl - j;x ++,y ++){
                    if((top[y] - ‘0‘) + (down[x] - ‘0‘) <= 3){
                        ++ sub;
                    }else { sub = 0; break; }
                }
                int t = max - sub;
                if(t < min) min = t;
                ++ j;
            }
            printf("%d\n",min);
        }
    }
    return 0;
}

[算法竞赛入门经典]Kickdown ACM/ICPC NEERC 2004,UVa1587

标签:switch   ott   tee   get   single   leading   mob   wan   block   

原文地址:https://www.cnblogs.com/1Kasshole/p/9691030.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!