码迷,mamicode.com
首页 > 编程语言 > 详细

Java练习 SDUT-1239_水仙花数

时间:2018-09-26 13:54:12      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:ext   str   i++   包括   sys   amp   else   ret   mem   

水仙花数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

春天是鲜花的季节,水仙花就是其中最迷人的代表,数学上有个水仙花数,是这样定义的:
“水仙花数”是指一个三位数,它的各位数字的立方和等于其本身,比如:153=13+53+33。
现在要求输出所有在m和n范围内的水仙花数。

Input

输入数据有多组,每组占一行,包括两个整数m和n(100<=m<=n<=999)。

Output

对于每个测试实例,要求输出所有在给定范围内的水仙花数,就是说,输出的水仙花数必须大于等于m,并且小于等于n,如果有多个,则要求从小到大排列在一行内输出,之间用一个空格隔开;
如果给定的范围内不存在水仙花数,则输出no;
每个测试实例的输出占一行。

Sample Input

100 120
300 380

Sample Output

no
370 371

import java.util.*;

public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        int i,n,m,num,a[] = new int[10000];
        int f,b[] = new int [10];
        num = 0;
        for(i=100;i<=999;i++)
            if(judge(i)==1)
                a[num++] = i;
        //153 370 371 407;
        while(cin.hasNext())
        {
            f = 0;
            n = cin.nextInt();
            m = cin.nextInt();
            for(i=0;i<num;i++)
                if(a[i]>=n&&a[i]<=m)
                    b[f++] = a[i];
            if(f==0)
                System.out.println("no");
            else
                for(i=0;i<f;i++)
                    if(i==f-1)
                        System.out.println(b[i]);
                    else
                        System.out.print(b[i]+" ");
        }
        cin.close();
    }
    public static int judge(int x)
    {
        int a,b,c;
        a = x / 100;
        b = x / 10 % 10;
        c = x % 10;
        if(a*a*a+b*b*b+c*c*c==x)
            return 1;
        return 0;
    }
}

Java练习 SDUT-1239_水仙花数

标签:ext   str   i++   包括   sys   amp   else   ret   mem   

原文地址:https://www.cnblogs.com/luoxiaoyi/p/9706415.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!