码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 2367 Genealogical tree 拓扑排序入门题

时间:2018-10-22 16:44:54      阅读:167      评论:0      收藏:0      [点我收藏+]

标签:print   dfa   inpu   ++   ural   appear   together   nothing   拓扑   

Genealogical tree
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8003   Accepted: 5184   Special Judge

Description

The system of Martians‘ blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there‘s nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member‘s children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers‘ numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source

 
code:
#include<stdio.h>
#include<iostream>
#include<math.h>
#include<string.h>
#include<set>
#include<map>
#include<list>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long LL;
int mon1[13]= {0,31,28,31,30,31,30,31,31,30,31,30,31};
int mon2[13]= {0,31,29,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]= {{0,1},{0,-1},{1,0},{-1,0}};

int getval()
{
    int ret(0);
    char c;
    while((c=getchar())== ||c==\n||c==\r);
    ret=c-0;
    while((c=getchar())!= &&c!=\n&&c!=\r)
        ret=ret*10+c-0;
    return ret;
}

#define max_v 105
priority_queue<int,vector<int>,greater<int> > q;
int indegree[max_v];
int G[max_v][max_v];
int n,m;
void inittp()
{
    for(int i=1;i<=n;i++)
        if(indegree[i]==0)
            q.push(i);//入度为0的点放入优先队列,优先队列是为了考虑字典序输出
}
void tpsort()
{
    int temp;
    int c=1;
    while(!q.empty())
    {
        temp=q.top();
        q.pop();
        if(c!=n)
        {
            printf("%d ",temp);
            c++;
        }else
        {
            printf("%d\n",temp);
        }
        for(int i=1;i<=n;i++)
        {
            if(G[temp][i])//存在边
            {
                indegree[i]--;//i点入度--
                if(indegree[i]==0)//若入度为0则放入队列
                    q.push(i);
            }
        }
    }
}
int main()
{
    int x;
    while(~scanf("%d",&n))
    {
        memset(indegree,0,sizeof(indegree));
        memset(G,0,sizeof(G));
        for(int i=1;i<=n;i++)
        {
            while(1)
            {
                scanf("%d",&x);
                if(x==0)
                    break;
                if(G[i][x]==0)//防止重边增加入度
                {
                    G[i][x]=1;
                    indegree[x]++;
                }
            }
        }
        inittp();
        tpsort();
    }
    return 0;
}

 

POJ 2367 Genealogical tree 拓扑排序入门题

标签:print   dfa   inpu   ++   ural   appear   together   nothing   拓扑   

原文地址:https://www.cnblogs.com/yinbiao/p/9830603.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!