码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 1696 Space Ant (极角排序)

时间:2018-10-29 23:00:20      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:order   lse   oss   include   die   color   tran   values   net   

题目:

Description

The most exciting space discovery occurred at the end of the 20th century. In 1999, scientists traced down an ant-like creature in the planet Y1999 and called it M11. It has only one eye on the left side of its head and just three feet all on the right side of its body and suffers from three walking limitations: 
  1. It can not turn right due to its special body structure. 
  2. It leaves a red path while walking. 
  3. It hates to pass over a previously red colored path, and never does that.

The pictures transmitted by the Discovery space ship depicts that plants in the Y1999 grow in special points on the planet. Analysis of several thousands of the pictures have resulted in discovering a magic coordinate system governing the grow points of the plants. In this coordinate system with x and y axes, no two plants share the same x or y
An M11 needs to eat exactly one plant in each day to stay alive. When it eats one plant, it remains there for the rest of the day with no move. Next day, it looks for another plant to go there and eat it. If it can not reach any other plant it dies by the end of the day. Notice that it can reach a plant in any distance. 
The problem is to find a path for an M11 to let it live longest. 
Input is a set of (x, y) coordinates of plants. Suppose A with the coordinates (xA, yA) is the plant with the least y-coordinate. M11 starts from point (0,yA) heading towards plant A. Notice that the solution path should not cross itself and all of the turns should be counter-clockwise. Also note that the solution may visit more than two plants located on a same straight line. 
技术分享图片

Input

The first line of the input is M, the number of test cases to be solved (1 <= M <= 10). For each test case, the first line is N, the number of plants in that test case (1 <= N <= 50), followed by N lines for each plant data. Each plant data consists of three integers: the first number is the unique plant index (1..N), followed by two positive integers x and y representing the coordinates of the plant. Plants are sorted by the increasing order on their indices in the input file. Suppose that the values of coordinates are at most 100.

Output

Output should have one separate line for the solution of each test case. A solution is the number of plants on the solution path, followed by the indices of visiting plants in the path in the order of their visits.

Sample Input

2
10
1 4 5
2 9 8
3 5 9
4 1 7
5 3 2
6 6 3
7 10 10
8 8 1
9 2 4
10 7 6
14
1 6 11
2 11 9
3 8 7
4 12 8
5 9 20
6 3 2
7 1 6
8 2 13
9 15 1
10 14 17
11 13 19
12 5 18
13 7 3
14 10 16

Sample Output

10 8 7 3 4 9 5 6 2 1 10
14 9 10 11 5 12 8 7 6 13 4 14 1 3 2

题意:有一只虫子只能左转 类似于贪吃蛇 不能走自己经过的点 询问最长路径
思路:找到左下的点 然后进行极角排序

代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int inf=0x3f3f3f3f;
const double eps=1e-10;
int tt,n,pos;

int dcmp(double x){
    if(fabs(x)<eps) return 0;
    if(x<0) return -1;
    else return 1;
}

double sqr(double x){
    return x*x;
}

struct Point{
    int id;
    double x,y;
    Point(){}
    Point(double a,double b):x(a),y(b){}
    friend Point operator + (const Point &a,const Point &b){
        return Point(a.x+b.x,a.y+b.y);
    }
    friend Point operator - (const Point &a,const Point &b){
        return Point(a.x-b.x,a.y-b.y);
    }
    friend Point operator * (const Point &a,const double b){
        return Point(a.x*b,a.y*b);
    }
    friend Point operator * (const double a,const Point &b){
        return Point(a*b.x,a*b.y);
    }
    friend Point operator / (const Point &a,const double b){
        return Point(a.x/b,a.y/b);
    }
    double norm(){
        return sqrt(sqr(x)+sqr(y));
    }
}t[110];

double det(const Point &a,const Point &b){
    return a.x*b.y-a.y*b.x;
}

double dis(const Point &a,const Point &b){
    return (a-b).norm();
}

bool cmp(const Point &a,const Point &b){
    double tmp=det((a-t[pos]),b-t[pos]);
    if(dcmp(tmp)==0) return dis(t[pos],a)<dis(t[pos],b);
    else if(dcmp(tmp)<0) return false;
    else return true;
}

int main(){
    scanf("%d",&tt);
    while(tt--){
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%d%lf%lf",&t[i].id,&t[i].x,&t[i].y);
            if(t[i].y<t[0].y || (t[i].y==t[0].y && t[i].x<t[0].x))
                swap(t[0],t[i]);
        }
        pos=0;
        for(int i=1;i<n;i++){
            sort(t+i,t+n,cmp);
            pos++;
        }
        printf("%d",n);
        for(int i=0;i<n;i++){
            printf(" %d",t[i].id);
        }
        printf("\n");
    }
    return 0;
}

 

 

POJ 1696 Space Ant (极角排序)

标签:order   lse   oss   include   die   color   tran   values   net   

原文地址:https://www.cnblogs.com/whdsunny/p/9873783.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!