码迷,mamicode.com
首页 > 系统相关 > 详细

Eclipse+pydev环境搭建

时间:2018-11-09 16:06:09      阅读:20      评论:0      收藏:0      [点我收藏+]

标签:ofo   复选框   version   blog   选项   window   创建   conf   item   

Eclipse+pydev环境搭建

编辑器: Eclipse + pydev插件

1. Eclipse是写JAVA的IDE, 这样就可以通用了,学习代价小。  学会了Eclipse, 以后写Python或者JAVA 都可以。

2. Eclipse, 功能强大。

3. Eclipse跨平台, 可以在Mac上和Windows运行

 

安装Python

下载地址:http://www.python.org/

Python 有 Python 2 和 Python 3 两个版本。  语法有些区别。  保险起见, 我安装Python 2.7.6

 

安装JAVA JDK

下载地址:http://www.oracle.com/technetwork/java/javase/downloads/index.html

Eclipse 需要这个安装好JAVA JDK后才能运行

 

下载Eclipse

http://www.eclipse.org/downloads/     到这下载。 

下载完后,解压就可以直接使用,  Eclipse不需要安装。

 

pydev插件介绍

pydev插件的官方网站: http://www.pydev.org/(不需要下载)

 

在Eclipse中安装pydev插件

启动Eclipse, 点击Help->Install New Software...   在弹出的对话框中,点Add 按钮。  Name中填:Pydev,  Location中填http://pydev.org/updates

然后一步一步装下去。  如果装的过程中,报错了。 就重新装。

技术分享图片

技术分享图片

 

配置pydev解释器

安装好pydev后, 需要配置Python解释器。

在Eclipse菜单栏中,点击Windows ->Preferences.   

在对话框中,点击pyDev->Interpreter - Python.  点击New按钮, 选择python.exe的路径, 打开后显示出一个包含很多复选框的窗口. 点OK

如果是Mac系统, 点击“Auto Config” 按钮

技术分享图片

 

开始写代码

启动Eclipse,  创建一个新的项目,   File->New->Projects...   选择PyDev->PyDevProject 输入项目名称.

技术分享图片

 

新建 pyDev Package.    就可以写代码了。

 

技术分享图片

 输入包名,这里输入Test1

技术分享图片 

 

重启eclipse时候发现,Pydev这个选项到处找都找不到,在【Window】->【Preference】里面找不到,新建项目的时候也没有Pydev这项目选项。

1. 原因

后来在pydev的官网:http://www.pydev.org/ 上找到了问题的原因。

原来,因为我安装的是JDK7(也就是Java 7),而Pydev的最新版5.0.0是需要Java 8的。支持Java 7的最后一个版本是pydev 4.5.5。

技术分享图片
pydev 4.5.5最后支持java7的版本.png

2. 解决办法

既然如此,那我们安装pydev 4.5.5就行了。

可以看到下面有这么一句:

See: update sites page for the update site of older versions of PyDev.

如果需要安装旧版本的pydev,去update sites page。 那就打开这个网站,找到pydev 4.5.5. 链接如下:http://www.pydev.org/update_sites/index.html

打开之后,可以看到pydev 4.5.5版本的插件更新的地址为:

http://www.pydev.org/update_sites/4.5.5/

点击菜单【help】->【Install New Software】,输入上面Pydev 4.5.5的地址。然后选择PyDev和PyDev Mylyn Integration,按照提示一步步完成。完成之后,重启eclipse,就可以看到PyDev了。

技术分享图片
 
 

http://www.cnblogs.com/zhmhhu/p/5867136.html

http://www.cnblogs.com/zhmhhu/p/6068416.html

卸载eclipse中的pydev

  1.  在Eclipse中依次点击菜单"Help"->"About Eclipse"。

  2. 点击"Installation Details"按钮,

    技术分享图片

  3. 选中要卸载的插件,点击"Uninstall..."按钮。

  4. 卸载完成后重启Eclipse即可。

Eclipse+pydev环境搭建

标签:ofo   复选框   version   blog   选项   window   创建   conf   item   

原文地址:https://www.cnblogs.com/smarter/p/9934899.html

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!