码迷,mamicode.com
首页 > 编程语言 > 详细

Java练习 SDUT-3848_Shift Dot

时间:2018-11-10 12:34:12      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:inpu   ble   题目   ring   close   rgs   main   void   i++   

Shift Dot

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

给出平面直角坐标系中的一点,并顺序给出n个向量,求该点根据给定的n个向量位移后的位置。

Input

多组输入,第一行是三个整数x,y,n,表示点的坐标(x,y),和向量的个数n。接下来n行,每行两个数xi,yi,表示第i个向量。题目中所有数据不会超出整形范围。

Output

每组输入输出一行,"(x,y)"表示点的最终位置。

Sample Input

0 0 1
2 3
0 0 2
1 2
2 3

Sample Output

(2,3)
(3,5)

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        point a,b;
        int n,i;
        while(cin.hasNext())
        {
            a = new point(cin.nextInt(),cin.nextInt());
            n = cin.nextInt();
            for(i=0;i<n;i++)
            {
                b = new point(cin.nextInt(),cin.nextInt());
                a.sum(b);
            }
            System.out.printf("(%d,%d)\n",a.x,a.y);
        }
        cin.close();
    }
}

class point
{
    int x,y;
    point(int x,int y)
    {
        this.x = x;
        this.y = y;
    }
    void sum(point p)
    {
        this.x += p.x;
        this.y += p.y;
    }
}

Java练习 SDUT-3848_Shift Dot

标签:inpu   ble   题目   ring   close   rgs   main   void   i++   

原文地址:https://www.cnblogs.com/luoxiaoyi/p/9938478.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!