标签:lag set i++ contains str sample 不同 tps c++
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2062 Accepted Submission(s): 956
Problem Description
Lweb has a string S.
Oneday, he decided to transform this string to a new sequence.
You need help him determine this transformation to get a sequence which has the longest LIS(Strictly Increasing).
You need transform every letter in this string to a new number.
A is the set of letters of S, B is the set of natural numbers.
Every injection f:A→B can be treat as an legal transformation.
For example, a String “aabc”, A={a,b,c}, and you can transform it to “1 1 2 3”, and the LIS of the new sequence is 3.
Now help Lweb, find the longest LIS which you can obtain from S.
LIS: Longest Increasing Subsequence. (https://en.wikipedia.org/wiki/Longest_increasing_subsequence)
Input
The first line of the input contains the only integer T,(1≤T≤20).
Then T lines follow, the i-th line contains a string S only containing the lowercase letters, the length of S will not exceed 105.
Output
For each test case, output a single line "Case #x: y", where x is the case number, starting from 1. And y is the answer.
Sample Input
2
aabcc
acdeaa
Sample Output
Case #1: 3
Case #2: 4
Author
UESTC
Source
2016中国大学生程序设计竞赛 - 网络选拔赛
问题链接:HDU5842 Lweb and String
问题简述:
????统计不同字母的数量。
问题分析:
????统计问题用个标记数组标记一下出现过的字母就可以了,标记字母的同时进行统计。
程序说明:(略)
参考链接:(略)
题记:(略)
AC的C语言程序如下:
/* HDU5842 Lweb and String */
#include <stdio.h>
#define N 100000
char s[N + 1];
int main(void)
{
int n, ans, caseno = 0, i;
scanf("%d", &n);
while(n--) {
int flag[26] = {0};
scanf("%s", s);
ans = 0;
for(i = 0; s[i]; i++)
if(flag[s[i] - 'a'] == 0)
ans++, flag[s[i] - 'a'] = 1;
printf("Case #%d: %d\n", ++caseno, ans);
}
return 0;
}
标签:lag set i++ contains str sample 不同 tps c++
原文地址:https://www.cnblogs.com/tigerisland45/p/10206064.html