码迷,mamicode.com
首页 > 编程语言 > 详细

数组B:我想我需要一艘船屋

时间:2019-01-09 23:36:52      阅读:296      评论:0      收藏:0      [点我收藏+]

标签:class   3.1   turn   within   com   put   ted   lang   ima   

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

技术分享图片

 

Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

Hint

1.No property will appear exactly on the semicircle boundary: it will either be inside or outside.
2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.
3.All locations are given in miles.
 

实验代码

#include<stdio.h>
#include<math.h>
#define pi 3.1415927
int main()
{
	int n,i=1;
	int year;
	double x,y,r,s;  //定义浮点型变量,x,y,半径,面积 
	scanf("%d",&n);
	while(n--)
	 {
	 	scanf("%lf%lf",&x,&y);
	 	r=x*x+y*y;      //求半径的平方 
	 	s=pi*r/2.0;  //求半圆的面积
		year=(int)ceil(s/50.0);  /*ceil函数:返回大于等于表达式的最小整数 
		例如:ceil(15.8)=16,ceil(-15.8)=-15*/ 
		printf("Property %d: This property will begin eroding in year %d.\n",i++,year);
	  }
	  printf("END OF OUTPUT.\n");
	  return 0;
}

  

数组B:我想我需要一艘船屋

标签:class   3.1   turn   within   com   put   ted   lang   ima   

原文地址:https://www.cnblogs.com/lqx0123/p/10247375.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!